FJR Owners Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have a 2007 fjr. Every so often the fuel guage will only show a couple bars when the tank is topped up. Of course it then flashes because it is reading low fuel. A couple rides later it goes back to normal. It will then be ok for a week or two. Bike runs fine this whole time though. Just putting this out there if anyone has come across this.
 

·
Registered
Joined
·
1,682 Posts
I have a 2007 fjr. Every so often the fuel guage will only show a couple bars when the tank is topped up. Of course it then flashes because it is reading low fuel. A couple rides later it goes back to normal. It will then be ok for a week or two. Bike runs fine this whole time though. Just putting this out there if anyone has come across this.
Tim,

I have not heard of this glitch with the FJR, but for most vehicles, a fuel gauge error is often a matter of bad grounding. Check at the sender, and at the instrument panel, for corroded ground connections. Bright shiny metal should be secured firmly to bright shiny metal. A tiny droplet of silver-conductive grease will improve the grounding there, and helps to prevent corrosion. It takes very little, to give you good help. Excessive conductive grease can migrate and cause other problems, but it works very well when used sparingly on ground connections.
.
 

·
Premium Member
CBF1000 VFR800
Joined
·
8,269 Posts
Under the tank, the white and green connectors to the fuel pump each have a black ground wire, but it is shared at a junction a little further upstream. I haven't heard of sticky fuel senders on FJR's, but you could refresh those connections by unplugging/replugging.
Some fuels can build a varnish on fuel senders, perhaps go a couple of tanks with some Seafoam in the fuel, see if it improves.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Thx for everyone’s input . I will check the connections under the tank. I did a throttle body sync 2 weeks ago, so maybe the connectors did get jostled when I tilted my tank.
 
1 - 4 of 4 Posts
Top