2018 Cruise Control Light Flashing - Yamaha FJR Forum : Yamaha FJR Owners Forums
 7Likes
Reply
 
LinkBack Thread Tools
post #1 of 18 (permalink) Old 08-30-2020, 07:47 PM Thread Starter
Junior Member
Training wheels fitted!
 
Join Date: Aug 2020
Location: Ontario, Canada
Posts: 19
2018 Cruise Control Light Flashing

I made a trip this afternoon and CC was functioning normally. Stopped for half an hour, then went to ride back. The CC light just continuously flashed and no CC. I did not notice any other warning lights, just the CC light flashed when enabled and I couldn't get CC to work. When I got home I parked, turned off the bike for a minute, turned on, now CC works normally. Went for a spin, everything now appears normal.

I am assuming there was some sort of fault with the CC which prevented it from operating.

Questions:

Is there a way to diagnose the fault WITHOUT going to the dealer?

Would I need to source a 4 pin to std pin ODB2 adapter cable in order to read the codes with my ODB2 reader?

Has anyone else seen a problem like this and have any suggestions as to what the typical root causes are?

2018 FRJ1300ES Matte Cobalt Metallic Blue
mikester is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 08-30-2020, 08:01 PM
Senior Member
Farkle Trainee
 
Join Date: Jun 2020
Location: Auburn WA
Posts: 175
ok .. I know nothing about the fault codes .. but in general ..check your brake lights..if a bulb is out that can cause the CC to not activate , or ..are the brake lights on? ,, juggle either brake lever...as well as the clutch lever .. all these can cause ...in general ..CC problems be it a car truck or bike
skippy344! likes this.
Way8lifter is offline  
post #3 of 18 (permalink) Old 08-31-2020, 05:51 AM
Senior Member
High-G FJR Junkie!
 
rbentnail's Avatar
 
Join Date: Dec 2013
Location: Asheboro, NC, USA
Posts: 7,430
https://www.fjrowners.com/forums/9-f...stic-tool.html

Russ
2007A

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbentnail is offline  
 
post #4 of 18 (permalink) Old 08-31-2020, 07:14 AM
Senior Member
High-G FJR Junkie!
 
Bill Lumberg's Avatar
 
Join Date: Nov 2014
Location: Southeast
Posts: 2,842
Sticking lever or switch (probably brake).
Quote:
Originally Posted by mikester View Post
I made a trip this afternoon and CC was functioning normally. Stopped for half an hour, then went to ride back. The CC light just continuously flashed and no CC. I did not notice any other warning lights, just the CC light flashed when enabled and I couldn't get CC to work. When I got home I parked, turned off the bike for a minute, turned on, now CC works normally. Went for a spin, everything now appears normal.

I am assuming there was some sort of fault with the CC which prevented it from operating.

Questions:

Is there a way to diagnose the fault WITHOUT going to the dealer?

Would I need to source a 4 pin to std pin ODB2 adapter cable in order to read the codes with my ODB2 reader?

Has anyone else seen a problem like this and have any suggestions as to what the typical root causes are?
skippy344! likes this.

No commercials. No dictators.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2018 FJR1300ES Stealth Model

IBA# 69560
Bill Lumberg is offline  
post #5 of 18 (permalink) Old 09-01-2020, 08:53 PM
Senior Member
High-G FJR Junkie!
 
RaYzerman's Avatar
 
Join Date: Jan 2013
Location: Millgrove, ON, CA
Posts: 6,922
As Bill says.... clutch and brake lever switches, wheel sensors, sticking rear brake pedal would be the first places to check/clean/lube.
Diagnostics on 2016 up available only by OBD.

Ray
Keep yer stick on the ice....
2014 FJR1300A - Root Beer (sold)
2009 CBF1000A - Sienna Red
1999 VFR800Fi - Pearl Shining Yellow
RaYzerman is online now  
post #6 of 18 (permalink) Old 09-02-2020, 10:46 AM Thread Starter
Junior Member
Training wheels fitted!
 
Join Date: Aug 2020
Location: Ontario, Canada
Posts: 19
I got the ODB2 to 4 pin cable adapter and plugged it in. No error codes were present. Does Yammy do anything different on the ODB2 or is it safe to assume there were no codes thrown? Hopefully all the codes are available through the ODB2.

I am going to assume the problem was with something like the kick stand or brake switch.

2018 FRJ1300ES Matte Cobalt Metallic Blue
mikester is offline  
post #7 of 18 (permalink) Old 09-02-2020, 11:00 AM
Senior Member
Farkle Trainee
 
dravnx's Avatar
 
Join Date: Aug 2016
Location: santa rosa, ca.
Posts: 286
Was it the CC power indicator or the Set indicator that was flashing?

bike X miles=smiles
smiles bike=miles
smiles miles=bike.
It's simple math.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dravnx is offline  
post #8 of 18 (permalink) Old 09-02-2020, 04:54 PM Thread Starter
Junior Member
Training wheels fitted!
 
Join Date: Aug 2020
Location: Ontario, Canada
Posts: 19
Only the CC power indicator was flashing, no SET indicator was on.

2018 FRJ1300ES Matte Cobalt Metallic Blue
mikester is offline  
post #9 of 18 (permalink) Old 09-02-2020, 06:34 PM
Senior Member
High-G FJR Junkie!
 
RaYzerman's Avatar
 
Join Date: Jan 2013
Location: Millgrove, ON, CA
Posts: 6,922
CC issues usually due to sensors or switches..... may not be any codes.

Ray
Keep yer stick on the ice....
2014 FJR1300A - Root Beer (sold)
2009 CBF1000A - Sienna Red
1999 VFR800Fi - Pearl Shining Yellow
RaYzerman is online now  
post #10 of 18 (permalink) Old 09-02-2020, 09:18 PM
Junior Member
Training wheels fitted!
 
Join Date: Aug 2020
Posts: 2
I have the same exact issue on occasion on my 2013FJR. However it is rare and it has only happened when I'm already in motion and want to use the cruise control! (Yes - that is annoying!) By stopping, turning the bike off, restarting and engaging the cruise button 'ON' again it always resets. Consequently, I'm now just in the habit of automatically turning on the cruise button before leaving for a run and acknowledge it is not flashing, and it is always there to 'SET' when I need it. I have also observed I have never got the 'flashing' indication from a cold start. This issue seems to only happen when the bike is warmed up and in motion. I know this is not an ideal explanation of why this annoyance is happening, but this is how I manage this issue with little pain without making myself mental and having to pull over and stop and restart the bike to reset it. I love my cruise control.
2013fjr1300 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha FJR Forum : Yamaha FJR Owners Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome